En

Ubuntu - websocket-extensions vulnerability (2020-09-16)

来源:Ubuntu官网 发布日期:2020-09-16 阅读次数:376 评论:0

基本信息

发布日期:2020-09-16(官方当地时间)

更新类型:安全更新

更新版本:未知

感知时间:2020-09-16 21:52:01

风险等级:未知

情报贡献:TSRC

更新标题

USN-4502-1: websocket-extensions vulnerability

更新详情

ruby-websocket-extensions vulnerability
A security issue affects these releases of Ubuntu and its derivatives:
Ubuntu 20.04 LTS
Ubuntu 18.04 LTS
Ubuntu 16.04 LTS
Summary
websocket-extensions could be made to exhaust the server’s capacity to process incoming requests if it received specially crafted requests.
Software Description
ruby-websocket-extensions - Generic extension manager for WebSocket connections
Details
It was discovered that websocket-extensions does not properly parse special headers. A remote attacker could use this issue to cause regex backtracking, resulting in a denial of service. (CVE-2020-7663)
Update instructions
The problem can be corrected by updating your system to the following package versions:
Ubuntu 20.04 LTS
ruby-websocket-extensions - 0.1.2-1+deb9u1build0.20.04.1
Ubuntu 18.04 LTS
ruby-websocket-extensions - 0.1.2-1+deb9u1build0.18.04.1
Ubuntu 16.04 LTS
ruby-websocket-extensions - 0.1.2-1+deb9u1build0.16.04.1
To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.
In general, a standard system update will make all the necessary changes.
References
CVE-2020-7663
]]>

软件描述

Ubuntu是一个以桌面应用为主的Linux操作系统

CVE编号

TSRC分析

暂无

业界资讯

暂无

评论

提交评论 您输入的评论有误,请重新输入